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Introduction 

MageMob Inventory extension is used to manage inventory of products. It manages stock in/out of 

products, suppliers, purchase orders, pending products, pending orders; stock received, purchase invoice, 

barcode and history of product’s inventory. It will reduce one’s work to manage inventory of many 

products at a time. 

Note:  

• This extension works on the default inventory configuration setting of Magento. Manage Stock 

option should be set to ‘YES’. 

• Mobile App will only be provided for Ultimate Edition of MageMob Inventory.  

Benefits of MageMob Inventory 

Inventory management is a good practice for any company. If you are not keeping a watchful eye on your 

inventory or counting stock regularly, you are setting yourself up for potential inventory errors and 

challenges. Proper inventory management really can make or break your business! Keep the following 

benefits in mind as you weigh the cost of not implementing an inventory management strategy: 

 

• It will help you improve the accuracy of inventory orders. Helps you to figure out how much 

inventory you need to have on hand. 

• It leads to a more organized warehouse. Manage warehouse wise low stock quantity as well. 

• This inventory Management strategy will help you save time and money. It would help you have 

real time and monetary benefits. 

• MageMob Inventory will let admin manage warehouse stock details while placing sales orders. 

• It’s a fact that a good Inventory Management will help you hold the customers. The customers will 

visit your store again, if you provide timely deliveries. 

• With MageMob Inventory you can Warehouse facility in your inventory system to manage the 

inventory of Warehouse. 

• The Barcode scanning module integrated in this system will help you scan the barcode of products 

and also enter a unique barcode on your own. The Barcode scanning devices will be configured with 

the system and will help eliminate the manual process so that your employees can focus on more 

important areas of business. 
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Installation & Activation 

Pre-requisite 

• This extension is dependent on default inventory settings of Magento 

 

• This can be checked from System -> Configuration -> Catalog -> Inventory 

 

• Expand the ‘Product Stock Options’ and set the ‘Manage Stock’ option to ‘Yes’ 

Installation Steps 

Step 1: Check Permissions  

• Make sure the ‘‘app’’, ''skin'' and ''lib'' directories of your Magento and all directories inside it have 

full written permissions or set permissions on each directory equal to 777 or0777. 

Important! Change all permissions back after installation.              

 
• Read more about permission at 

www.magentocommerce.com/wiki/magentofilesystempermissions 

 

Step 2: Disable Compilation 

 

• Log into Magento Admin Panel and go to System -> Tools -> Compilation and disable the 

compilation. 

 

• After Step 5, you can run the compilation process again. 

 

Step 3: Upload Files 

 

• Upload all folders from the extension package to the installation directory of your Magento software 

using an FTP client. 

 

 

 

 

http://www.magentocommerce.com/wiki/magentofilesystempermissions
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Step 4: Clear cache 

 

• Go to System -> Cache Management. Clear the store cache. 

 

Step 5: Re-login 

 

• Logout and log back into Magento Admin Panel. 

 

Step 6: Use Extension 

 

• Go to System -> Configuration. In the left column you will see the new tab called Biztech Extensions. 

You will find ‘MageMob Inventory’ under Biztech extensions tab. 

 

 

Extension Activation 

 

Get activation key 
 

• Copy the activation key from the Order Confirmation Mail. OR Login into your account at website 

using the e-mail and password that you provided at checkout process. 

 

• Go to Downloadable Options and copy the activation key for the MageMob Inventory. 

 

Activate your extensions 

 

• Log into Magento Admin Panel and go to System Configuration -> Biztech Extensions / MageMob 

Inventory Activation and enter the activation key in the 'Activation Key' field for the MageMob 

Inventory extension then click the ‘Save Config’ 
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Select Websites 

 

• When you enter and save the key it will be verified and you can select the websites where you need 

to use the MageMob Inventory extension. Click the 'Save Config' button after making your 

selections. 

 
 

• After successful license validation, you can select the website. Now, your MageMob Inventory 

extension is activated. 
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How it Works? 

Back End Configuration 
 

• Please follow the below steps to configure MageMob Inventory extension. 
 

• Go to System -> Configuration 
 

• In the left column you will see the tab Biztech Extensions -> MageMob Inventory. 
 

Enable Extension & General Extension Configurations 

• Select ‘Yes’ to enable the extension. And Select ‘Yes’ to show all suppliers in Purchase Order 

creation. 
 

 
 

Extra Configurations for Professional+ Edition: 

 
 

• Choose Default warehouse for products. This warehouse will be considered as primary warehouse, 

when stock inserted first time and if no other warehouse is assigned than it will update in this 

warehouse primarily. 

 

• Choose warehouse level quantity after which pending order and pending products quantity will be 

displayed. 
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• Similarly, for any other website under the same instance choose it from ‘Current Configuration 

Scope’ and follow the above-mentioned steps for selecting default warehouse for the selected 

website. 

 
Note: When the customers purchase any of the product from any of the website included under the 

instance, the quantity of the product purchased will automatically be deducted from the specific product’s 

inventory. 
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Mange Suppliers 

• Go to MageMob Inventory -> Manage Suppliers. A grid of suppliers (if added) will be displayed. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

• To add a new supplier, click on ‘Add Supplier’ to add new supplier. 

 

 
For Professional Edition: 

• Admin can create a new supplier. To add a new supplier admin needs to add basic details of the 

supplier such as his name, email, company name, contact person’s name, shipping method and 

payment method. 

 

• Admin can select the status of the supplier as ‘Active’ or ‘Inactive’. 
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• Admin also needs to add the information related to the address from the ‘Supplier Address 

Information’.  
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• Admin can also associate products with the particular supplier. 
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Extra Features for Professional+ Edition: 

• Admin can add password for Supplier to enable front end supplier login. 
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Manage Stock 

• Go to MageMob Inventory -> Manage Stock. A grid of products (if added) with stock status will be 

displayed.  

 

• Using this module, admin can manage product’s quantity, stock status; add comments and status 

of the product as well. 

 

• Quantity entered by admin will directly be updated to the product; it will not add that quantity to 

existing. For example, if the existing quantity is “50” and the admin enters “55” in the text box then 

the final quantity of the product would be “55”.  

 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

• Admin can also import the products through CSV format file. 
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Extra Features for Professional+ Edition: 

• The Professional+ package allows the admin to increase / decrease the quantity of the product 

rather than giving total quantity. The increased / decreased quantity will be directly reflected in 

selected warehouse.  

 

• Admin will get product image on the grid itself to have a look at product. 

 

• The warehouse can be selected from ‘Select Warehouse’ drop down list given in the panel. 

 

• Admin can also export these products in CSV format but the decreased quantity must not be more 

than total available quantity in warehouse. 
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Pending Products 

• Go to MageMob Inventory -> Pending Products. This grid will show the products which are out of 

stock or their quantity is below low stock quantity. 

 

• Admin will get product image on the grid itself to have a look at product. 

 

• Admin can Sort or Search the records using various filters for fields in the grid.   
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• Admin can generate purchase order of selected products. 

 

• Selected products can be exported. 

 

 

Extra Features for Professional+ Edition: 

• Get warehouse wise pending quantity of products. 
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Pending Orders 

• Go to MageMob Inventory -> Pending Orders. This grid shows pending sales orders (orders in which 

one or more of the products are backordered) along with PO Order ID and Status. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

 
 

• Admin can also generate purchase orders by selecting the sales order. 

 

• Admin can select more than one sales order to generate purchase order. 
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Extra Features for Professional+ Edition: 

• Completed orders will be removed from pending orders grid. 
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Purchase Orders 

• Go to MageMob Inventory -> Purchase Orders. Admin can select products or orders to generate 

purchase orders. Click on ‘Create PO’ to generate new PO.  
 

• Admin can Sort or Search the records using various filters for fields in the grid. 
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• Admin can select the supplier want for each of the individual products. 

 

• Purchase orders are generated based on the supplier selected i.e. if admin selects two or more 

products from the same supplier then the ‘Required quantity’ would be added and the “Unit cost” 

would be the average of all the individual product costs.  
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• By clicking on ‘Submit’ button, admin can review the Purchase Order. 

 

• Admin can enter required date, comments, shipping method and payment method once the 

purchase orders are sorted by supplier. 

  

• Admin can send E-mail directly to the supplier also. 

 

 
 

Extra Features for Professional+ Edition: 

• Select Warehouse while Generating Purchase Order. 
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• Added Warehouse selection for order item on order view, this will be disabled after shipment 

generation. 
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Stock Received 

• Go to MageMob Inventory -> Stock Received. Admin can enter received quantity as per purchase 

order of the product. Admin can also make comment if any and can also add shipping cost. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 
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• Admin has rights to change the purchase order status to partial or complete. 

 

 
Extra Features for Professional+ Edition: 

• When stock is received, warehouse selection option is added in stock received page so that admin 

can update the stock directly to that warehouse. Associated warehouse with product will be 

displayed in stock received. Admin will also get product image on the grid. 
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Purchase Invoice 

• Go to MageMob Inventory -> Purchase Invoice. Admin can generate purchase invoice per purchase 

order. Admin can add comments to it. 

 

• Admin can also Sort or Search the records using various filters for fields in the grid.   
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Extra Features for Professional+ Edition: 

Manage Warehouse 

• Go to MageMob Inventory -> Inventory Warehouses. A grid of warehouses will be displayed from 

where warehouses can be searched or created. 

 

• Basic details of warehouses are displayed and is the warehouse primary or not is shown. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 
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• Admin can associate products to warehouse with necessary quantity. Admin can also increase and 

decrease quantity of the products from warehouse associated products grid. In this grid admin will 

have product images along with product available quantity and product total quantity. 
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Manage Inventory History 

• Go to MageMob Inventory -> Inventory Log. A grid of products altered using any action will be 

displayed. 

 

• On altering the quantities of product, it will be traced here. 

 

• Admin can get the idea of the product quantity, whether it is increased or decreased. 

 

• Admin can also Sort or Search the records using various filters for fields in the grid. 

 

• Warehouse transaction log has been added to this module. Admin can now have idea of the 

transaction happened on warehouse also. 
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Barcode 

 

• Go to MageMob Inventory -> Barcode. Admin can generate barcode for products. Admin can 

generate multiple barcode for single products with different suppliers, purchase orders. 

 

• Admin can give their own code, necessarily it should be unique. 

 

• Admin can also Sort or Search the records using various filters for fields in the grid. 
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• One can scan barcode; it will fetch the barcode, product & supplier details from it. 

 

• Admin can also update the stock of product fetched from barcode scan. 

 

• Details of warehouses are available in barcode view details. 

 

• When barcode is scanned admin can add the desired stock to the warehouse. 
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Extra Features for Ultimate Edition: 

• It includes all the features of Basic and Advance versions with Mobile Compatibility. 

 

Inventory System Enterprise General Configuration 

 

• New Order Notification Message: Enter message which will be received on the Mobile app 

whenever a New Order is received. 

 

• New Customer Register Notification Message: Enter message which will be received on the Mobile 

app whenever a New Customer is registered. 

 

• Minimum Quantity Required For Product: Enter minimum quantity required for product inventory 

alerts. 

 

• Product Inventory Notification Message: Enter message which will be received on the Mobile app 

whenever a product quantity is lower than or equal to minimum quantity. 

 

• Store Base URL QRcode: Scan the QR code to view and configure the store base URL on your device. 
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Dashboard 

• To view the Dashboard, navigate to ‘Dashboard’. It is an easy to manage dashboard that can be 

customized as per your business needs. It also allows viewing dashboard of multiple stores. 

 

• It can help you get all relevant details about orders, products and customers thus keeping you 

updated about your online store. 

 

▪ Displays current year sales 

 

▪ Average monthly order value 

 

▪ Number of orders placed 

 

▪ A complete report of total sales etc. 
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Manage Products 

• To manage products, go to Catalog -> Manage Products. A grid of products will be displayed. Click 

on ‘Add Product’ to add new Products. 
 

• Admin can Sort or Search the records using various filters for fields in the grid. 
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• Admin can add new products by providing the major Product Information and Edit Products by 

updating the Product Information from the Manage Products section.  
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Manage Customers 

• To manage Customers, go to Customers -> Manage Customers. A grid of Customers will be 

displayed.  
 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

• Admin can also add new customers and to add new customers click on ‘Add Customers’. 
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• Now provide the Account Information and the Address of the Customer and click on ‘Save 

Customer’ to save the customer. 
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• To edit the customer, click on ‘Edit’ button from the Manage Customers grid. By clicking on the 

‘Edit’ button admin will be redirected to the Edit Page of the particular customer also admin can 

manage complete details of the customer from the edit page. 
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Manage Sales Order 

• To manage Sales Order, go to Sales -> Orders. A grid of Sales Orders with its details will be displayed.  
 

• The Orders can be exported in CSV and Excel XML from the ‘Export To’ dropdown list. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 
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• By clicking on the ‘View’ button besides the Orders admin can view the complete details of the 

particular Order. Thereafter to delete any of the orders select the Order and click on ‘Delete’ button.  
 

 
 

  



 
USER MANUAL – MageMob Inventory 
 

BIZ/UMP/G1 Public  40 

 

• Admin can also generate the shipments for the Sales Orders of the customers. 
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Manage Reviews 

• To manage Reviews, go to Catalog -> Reviews and Ratings. Reviews will be of two type; All Reviews 

and Pending Reviews. 

 

• To view all the reviews, navigate to Catalog -> Reviews and Ratings -> Customer Reviews -> All 

Reviews.  A grid of all the reviews with its details will be displayed. 

 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

• Admin can Add, Edit and Delete reviews from this grid. Thereafter admin can also update the Status 

of the Reviews from the ‘Actions’ dropdown list. 
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• To view Pending Reviews, navigate to Catalog -> Reviews and Ratings -> Customer Reviews -> 

Pending Reviews.  A grid of Pending reviews with its details will be displayed. 
 

• Admin can Sort or Search the records using various filters for fields in the grid. 

 

• Admin can Edit and Delete reviews from this grid. Thereafter admin can also update the Status of 

the Reviews from the ‘Actions’ dropdown list. 
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Points to Note 

• Products in all the modules of MageMob Inventory will only be visible if they are assigned to the 

website selected while purchasing the Extension. 

 

• Limit of quantity of product to be out of stock is configured from Magento admin. 

 

• In Pending orders only, those sales orders will be displayed which are placed from the store/website 

selected at the time of purchasing Extension. 

 

• If same products are there in more than one pending orders which are selected for generating 

purchase orders, then you can remove the product from selection otherwise it will take the average 

of the unit cost entered for that product based on the summation of the required quantity entered. 

 

• Biztech provides Magmi Support (v0.7.23) with MageMob Inventory’s Professional+ and Ultimate 

Edition. 

 

• Default warehouse will be added automatically on activation of MageMob Inventory. 
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FAQ 

General FAQ 

1. Will the mobile app work on Android and iOS? 

Ans: Yes, the app is available for both Android and iOS. You can download from the respective stores. 
 
2. Do I need to install anything on Magento? 

 
Ans: Yes, you need to install the “MageMob Inventory” extension on Magento. 

 
3. Do you provide demo? 

 
Ans: Yes, demo is worth a thousand words. You can view the demo details and video on our store page. 
 
4. Will I be able to upgrade it from a lower plan to a higher plan? 

 
Ans: Yes, you can upgrade it, - by paying the balance amount. 
 
5. Do you provide installation service? 

 
Ans: Yes, we do provide the installation service. You can tick the installation service checkbox while 
purchasing or can transfer the mentioned amount to our PayPal account 
payments@biztechconsultancy.com  later on. 
 
6. Can I edit the extension? 

 
Ans: All our extensions are 100% open source. You can customize the extension except the file 
containing our license code. 
 
7. What if I get an error message after the installation of extension or 404 Error Page not found, 

after installing extension? 
 

Ans: No need to worry. Just log out of your Magento admin panel and login in again. 
 
8. Can you customize the extension and app as our store needs? 

 
Ans: Yes, we do customize the extension and app as per your need. This requires extra effort and 
estimation. 
 
9. Do you have a refund policy? 

 

Ans: Yes, you can refer our refund policy @ https://www.appjetty.com/refund-policy.htm.We stand 

behind the quality of our extensions with a 15-day money back guarantee. 

 

  

mailto:payments@biztechconsultancy.com
https://www.appjetty.com/refund-policy.htm
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Technical FAQ: 

 
1. What to do if I cannot login the app? 

 
Ans: Please ensure that you are using the correct username, password and URL. You can get the correct 
URL to enter by following the below mentioned steps:  
 

▪ Login to your admin panel.  

 

▪ Go to System -> Configuration - MageMob Admin.  

 

▪ Look for “Store Base URLQR code” and scan it with your device. 

 

▪ This will show you the URL to be entered while signing in the app.  

Note: If you have set “Add Store Code to URLs” to “Yes”, then kindly append the store code to the URL 
to login with the app. You can check the setting at following path: System -> Configuration -> Web -> 
URL Options -> Add Store Code to URLs. 
 
2. What if my admin panel goes unreachable after installing the extension? 

 
Ans: It can be the “ALL” module conflict as well. You can refer the answer of previous question. 

 
3. The app is not working fine on Android 6.0. What may the reason? 

 
Ans: Please ensure that you have granted required permissions for the app. For enabling permissions, 
please go to Settings -> Apps -> MageMob Admin -> Permissions and enable all required permissions 
to make the app work properly. 

 
4. Is SOAP user required? 

 
Ans: No, with the latest version of extension and app, the SOAP user is no longer required. You can 
login the app with admin credentials only. 
 
5. What if after trying all your suggestions, still cannot login the app? 

 
Ans: There must be some major 3rd party extension conflicts. You can shoot and email at 
support@appjetty.com  for further seamless support. 
 
6. What if I do not want to set product dimensions for all products (Height, Width and Length)? 

 
Ans: We have given provision in our extension that you can set default height, width and length from 
admin and it will be same for all products. Also, if any of your product will have dimension, then first it 
will give priority to that product's dimension and secondly to default configurations. 
 
7. What sort of notifications will be received in the app? 

 
Ans: You will receive the following notifications based on your back-end configuration:  
 

▪ Order notification  

 

▪ Product notification 

mailto:support@appjetty.com
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▪ Customer notification  

 

▪ Review notification. 

 
8. Can the notification message be customized? 

 
Ans: Yes, you can provide the notification message for new order placed, new customer registered and 
new review added for product. 
 
9. Is there any alert notification for products running out of stock? 

 
Ans:  Yes, you need to set the minimum quantity required for product and the notification message to 
be displayed in the app when the product’s quantity goes less than or equal to threshold. 

 
10. Is it mandatory creating a default warehouse for products? 

 
Ans: No, once you install our extension, a default warehouse will be created and the products 
thereafter will be assigned to this primary warehouse if the warehouse is not specified.  

 
11. Is there a way out to see who updated the product quantity? 

 
Ans: Yes, we have a module called “Inventory log” which will provide you the following information:  

▪ Product SKU (which product’s quantity has been altered)  

 

▪ System action (quantity has been altered using which action)  

 

▪ Action type quantity has been increased or decreased)  

 

▪ Product’s quantity before and after the action 

 

▪ Processed date  

 

▪ Interface (mobile or desktop)  

 

▪ User. 

 
12. What is the difference between “Pending products” and “Pending Orders”? 

 
Ans: Pending products will list the products which are “Out of Stock” and need to order them from 
supplier to get them back in stock. Pending orders will the list the orders which are backordered and 
you need to purchase from supplier to fulfill the sales orders. 

 
13. Can single purchase order have multiple stocks received? 

 
Ans: Yes, as we allow partial delivery, single PO can have multiple SR. 
 
14. Is it possible to create purchase order for different suppliers at a time? 

 
Ans: Yes, you can select multiple suppliers in the PO generation at a time. But PO for multiple suppliers 
will be generated different. 
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15. What if the unit cost changes (increases/decreases) when stock is received against PO? 
 

Ans: We do have a provision to enter the unit cost while the stock is received. You can also enter the 
shipping cost if any. 
 
16. I have multiple stocks received for single purchase order. Is it allowed to create purchase invoice 

for each stock received? 
 

Ans: No, purchase invoice will be created per purchase order. 
 

Contact Us 

We simplify your business, offer unique business solution in digital web and IT landscapes. 
  

 
 
 

 

 

 

 

 

 

 
 
Customization: 
If you would like to customize or discuss about additional feature for MageMob Inventory please write 

to sales@appjetty.com 

 

 

 

 
Tickets 

 

• Raise tickets for your specific question! 

 
• Send an email to support@appjetty.com 

or you can login to your account @ 

www.appjetty.com and click on My Sup-

port Tickets on your account dashboard, 

to get answers to your specific questions.  

 

 
Live Chat 

 
• Get instant support with our Live Chat. 

 

• Visit our product page at: 

https://www.appjetty.com/magento-

magemob-inventory.htm and click on 

the Live Chat button for instant support. 

 

mailto:sales@appjetty.com
mailto:support@appjetty.com
https://www.appjetty.com/magento2-magemob-inventory.htm
https://www.appjetty.com/magento-magemob-inventory.htm
https://www.appjetty.com/magento-magemob-inventory.htm

